Nhóm lỗi remote desktop
- Trường hợp 1: The user's password must be changed before signing in
- Trường hợp 2: Màn hình nháy liên tục
- Trường hợp 3: Because of an error in data encryption, this session will end
- Trường hợp 4: Could not establish connection to
- Trường hợp 5: Your Remote Desktop Services session has ended
- Trường hợp 6: The logon attempt failed
- Trường hợp 7: An internal error has occurred
- Trường hợp 8: Remote Desktop can't connect to the remote computer for one of these reasons
- Trường hợp 9: The security account manager (sam) or local security authority (lsa) server was in the wrong state
Trường hợp 1: The user's password must be changed before signing in.
Mô tả
Server đang sử dụng bình thường bỗng một ngày bị lỗi remote không thể đăng nhập được và bắt đổi mật khẩu.
Nguyên nhân có thể
- Do điều khoản bảo mật của Windows bắt buộc người dùng phải đổi mật khẩu định kì.
Hướng dẫn xử lí
- Gửi tài liệu đổi password server Windows cho khách hàng.
Trường hợp 2: Màn hình nháy liên tục
Mô tả
Khách hàng remote vào server nhưng server bị hiện tượng màn hình nháy liên tục
Nguyên nhân có thể
- Do màn hình remote desktop không đúng size
- Do server bị full tài nguyên sử dụng CPU
Hướng dẫn xử lí
- Báo lại khách hàng remote trên thiết bị khác xem còn tình trạng không.
- kiểm tra metrics của server xem có bị full CPU không, nếu có thực hiện reboot.
Trường hợp 3: Because of an error in data encryption, this session will end ...
Mô tả
Khách hàng Remote desktop vào server windows server và bị tình trạng lỗi như hình
Nguyên nhân có thể
- Do network của khách hàng bị chập chờn không kết nối được.
- Do phiên đăng nhập vào Remote bị hết.
- Do máy tính được remote bởi thiết bị khác.
Hướng dẫn xử lí
- Báo khách hàng kiểm tra lại network.
- Kiểm tra lại kết nối của server thông qua ping, remote hoặc console.
- Kiểm tra xem có thiết bị khác kết nối remote đồng thời hay không. Lưu ý chỉ 1 thiết bị kết nối remote.
Trường hợp 4: Could not establish connection to "..."
Mô tả
Khách hàng kết nối với server và bị lỗi như hình.
Nguyên nhân có thể
- Do server bị quá tải tài nguyên.
- Do bị chặn port kết nối.
- Do network khách hàng gặp vấn đề.
- Do ứng dụng khách hàng dùng để kết nối server gặp vấn đề.
Hướng dẫn xử lí
- Kiểm tra metrics của server có ổn đinh hay không.
- Thử kết nối với server thông qua ping, remote hay noVNC xem có được hay không.
- Kiểm tra network phía bên khách hàng.
- Hướng dẫn khách hàng kết nối thông qua putty (với linux) hoặc remote desktop (với windows)
Trường hợp 5: Your Remote Desktop Services session has ended.
Mô tả
Khách hàng không thể remote được vào server, không thể connect được server bằng chức năng mở console.
Nguyên nhân có thể
- Do network trên máy tính của khách hàng gặp vấn đề chập chờn đẫn tới quá thời gian phiên kết nối.
Hướng dẫn xử lý
- Báo khách hàng sử dụng mạng tốt hơn để kết nối.
Trường hợp 6: The logon attempt failed
Mô tả
Khách hàng mới tạo server không thể Remote được, trong khi vẫn có thể connect được server bằng chức năng mở console và mọi thứ hoàn toàn bình thường.
Nguyên nhân có thể
- Do lỗi hệ thống khi tạo server.
Hướng dẫn xử lý
- Báo khách hàng Reset lại mật khẩu.
Trường hợp 7: An internal error has occurred.
Mô tả
Khi dùng remote desktop tới server, nhập địa chỉ ip và chọn Connect thì màn hình báo lỗi như sau
Nguyên nhân
- Có thể do server bạn sử dụng là linux không có sẵn chức năng Remote Desktop.
- Có thể server đang tắt hoặc offline.
- Do port remote bị chập chờn kết nối dẫn đến việc lúc vào được, lục không
Cách khắc phục
- Đổi sang server Window để kết nối.
- Trường hợp muốn kết nối Remote Desktop trên Linux có thể cài XRDP theo hướng dẫn sau: Kết nối Remote Desktop cho Ubuntu và CentOS trên Window
- Nếu server đăng tắt hoặc offline, kiểm tra lại mạng hoặc tình trạng server đang on hay off.
- Kiểm tra network của server (ping, port)
- Thực hiện đổi port remote cho server theo hướng dẫn sau: Thay đổi port remote desktop
Trường hợp 8: Remote Desktop can't connect to the remote computer for one of these reasons: ...
Mô tả
Khi kết nối, màn hình Remote load một lúc rồi báo lỗi như hình:
Nguyên nhân
- Do tài khoản bạn đang chạy Remote không có quyền Remote vào server
- Do server bị treo hoặc bị tắt.
- Do server mất kết nối.
- Do kết nối Remote bị chập chờn.
- Do server đổi port Remote
Cách khắc phục
- Kiểm tra server đã từng đổi port Remote hay chưa và port đó là port nào.
- Nếu server bị treo, restart lại server
- Thực hiện đổi Port Remote để tránh bị scanport theo tài liệu sau: Thay đổi port cho Remote desktop
- Kiểm tra lại tài khoản đăng nhập remote, thử sử dụng tài khoản Administrator để đăng nhập.
Trường hợp 9: The security account manager (sam) or local security authority (lsa) server was in the wrong state...
Mô tả
Khi thực hiện remote desktop thì xuất hiện lỗi, không thể connect được. Sử dụng chức năng mở console trên dashboard cũng bị lỗi tương tự.
Nguyên nhân
Do SAM thực hiện ghi trạng thái bị lỗi, có nhiều nguyên nhân dẫn tới lỗi này:
- Do file hệ thống bị corruptted.
- Do tài nguyên bị quá tải nên SAM không thể thực hiện ghi dữ liệu.
- Do server bị nhiễm malware, virus.
Cách khắc phục
- Tạm thời thực hiện restart lại server để có thể login được vào server.
- Trong trường hợp restart server vẫn không thể login được, có thể boot vào safemode (bằng cách nhấn F6 hoặc dùng chức năng reset password)
- Thực hiện check log hệ thống trong khoảng thời gian bị lỗi remote để tìm hiểu nguyên nhân SAM không thực hiện ghi trang thái được.
- Thực hiện quét virus trên server.